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What’s New in
RiverTools 2.4
RiverTools 2.4 is a powerful and yet easy-to-use GIS application that specializes in
the analysis and visualization of digital terrain, watersheds and river networks.
RiverTools makes it easy to import digital elevation data in a wide variety of formats,
including the SDTS Raster Profile format recently adopted by the USGS and many
more. In addition to raster formats, RiverTools 2.4 now supports the import, export
and display of ESRI Shapefiles, and the import and display of USGS Digital Line
Graphs in SDTS format.

RiverTools includes many specialized algorithms for the analysis of DEMs and
watersheds, including both D8 and D-Infinity flow algorithms, and state-of-the-art
methods for dealing with pits and flats. It can quickly measure stream attributes such
as length, drop, slope, curvature, upstream area, sinuosity, drainage density,
longitudinal profiles, longest channel length, Horton-Strahler order and many more,
for single channels or entire river networks. All of these measurements are made
using the currently selected ellipsoid model of the Earth, with built-in support for
over 50 different ellipsoids.

While many GIS applications have a simple scripting language for extending their
functionality, RiverTools can be extended with the full power of IDL, the Interactive
What’s New in RiverTools 2.4 5



6 What’s New in RiverTools 2.4
Data Language, and hundreds of low-level RiverTools commands. RiverTools also
runs identically on Windows, Mac, and UNIX platforms.
What’s New in RiverTools 2.4
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Overview of New Features

New File Import/Export Improvements – New file import capabilities now include
the ability to read NOAA/NOS EEZ Bathymetry files and GMT raster files. Support
for vector file formats has been expanded to include import, display and overlay of
ESRI Shapefiles and USGS SDTS files in Topological Vector Profile format.
RiverTools 2.4 also offers the ability to easily export vector data and attributes to
spreadsheets and other GIS Programs. See “New File Import/Export Improvements”
on page 9 for more information about these and other File menu improvements.

New Display Menu Functions – New Vector Graphic display capabilities include
the ability to import and plot ESRI Shapefiles and USGS Digital Line Graphs in
SDTS format. Another new Display menu feature allows you to plot a function that
has been saved as a text file. See “New Display Menu Dialogs” on page 15 for more
information.

New Prepare Menu Enhancements – New tools within the Prepare menu now
allow you to compress and uncompress any file that has been saved with the popular
GZIP algorithm. Other enhancements include improvements to the DEM mosaicking
dialog and creating RTI files for a set of USGS 1-Degree DEMs. See “New Prepare
Menu Enhancements” on page 17 for more information.

Enhanced Hydrologic Analysis Features – RiverTools 2.4 now supports continuous
flow angles and multiple flow directions via the D-Infinity algorithm. It also supports
two new options for routing flow through broad, flat valleys, more options for area-
altitude plots, and a new routine for “watershed segmentation.” See “Enhanced
Hydrologic Analysis Features” on page 20 for details about these and other new
Extract menu enhancements.

Enhanced Interactive Window Tools – All of the tool dialogs now feature an
Options menu that greatly expands their functionality and makes them easier to
configure. See “Enhanced Interactive Window Tools” on page 28 for more
information.

Expanded Help Features – Quickly find answers to your questions using the new
Windows online help feature or access help through new context-sensitive Help
buttons now available on many of the dialogs. See “Ease-of-Use Improvements” on
page 30 for more information on these features and enhanced Window menu features.

New Customization Features – New naming conventions for RiverTools routines
and a new ability to permanently modify the User menu make it easier to extend
RiverTools with user-written routines. See “New Customization Features” on
page 31 for more information.
What’s New in RiverTools 2.4 Overview of New Features



8 What’s New in RiverTools 2.4
New Data CD-ROM – RiverTools 2.4 also comes with a data CD-ROM full of
interesting digital terrain data in many different formats. This data is ideal for
teaching a course with RiverTools and for demonstrating the raster and vector import
capabilities. See “New Data CD-ROM” on page 32 for details.
Overview of New Features What’s New in RiverTools 2.4



What’s New in RiverTools 2.4 9
New File Import/Export Improvements

RiverTools 2.4 now includes two new formats in the File → Import DEM dialog and
expanded ability to grid irregular XYZ elevation data. New File → Export dialogs
support exporting ENVI and ArcView grid files, and exporting vector data to ESRI
Shapefiles or ASCII tables. Other File menu improvements include support for over
50 ellipsoid models of the earth and a new Printing Options dialog that replaces the
Page Layout dialog. The File menu also allows you to control various aspects of the
current RiverTools session by setting session preferences. See the following sections
for details.

Improved File > Import DEM Dialog

RiverTools 2.4 can import a wide variety of DEM formats, including ArcView (.bil),
ENVI, flat binary, GeoTIFF (.tif), USGS Standard (.dem), USGS SDTS (Raster
Profile, .ddf), DTED (.dt0, .dt1, .dt2), gridded ASCII, NOAA/NOS EEZ Bathymetry
and the GMT raster. The last two are new in this release. Note that GTOPO30,
ETOPO5, Mars MOLA and NED (National Elevation Data) DEMs are also
supported since they are distributed in formats listed above.

• File → Import DEM - NOAA/NOS EEZ Bathymetry — This new option
allows you to import NOAA/NOS EEZ Bathymetry data in either the
Geographic-based format (*.grd, *.prg) or the UTM-based format (*.dat,
*.pru).

• File → Import DEM - GMT Raster DEM — This new option allows you to
import DEMs in GMT's raster DEM format (*.grd), which is a special type of
netCDF file.

• File → Import DEM - Irregular XYZ — This routine creates a regular
binary grid from irregular XYZ ASCII data using two IDL routines called
TRIANGULATE and TRIGRID. The input file must be in ASCII format with
one XYZ triple per line.

Make sure to specify the correct pixel x,y units. This can often be inferred
from the min/max info. All x-values must be between -180 and 180, and all y-
values must be between -90 and 90 in order for Degrees to be an option. The
resulting size of the grid is determined by the bounding min/max values and
the pixel x-size and y-size that you specify. A RiverTools info file is also
created.

Other File importing improvements have been made to the File → Import DEM →
USGS Standard DEM and the File → Import DEM → USGS SDTS DEM
What’s New in RiverTools 2.4 New File Import/Export Improvements



10 What’s New in RiverTools 2.4
options. Both have been improved to create “smart” default DEM filenames based on
the USGS map title.

New File > Export Features

RiverTools now supports exporting data from RiverTools vector files (RTV) into
ESRI Shapefiles and multi-column text files, and exporting RiverTools grid files
(RTG) to four other grid formats. The File → Export Vector → Channels, File →
Export Vector → Boundaries and File → Export Grid dialogs offer enhanced
ability to export data and attributes and provide better integration with other GIS and
spreadsheet programs.

• File → Export Grid — New Export Grid features add support for GeoTIFF
and gridded ASCII formats. RiverTools, ENVI, and ArcView all store raster
data in flat binary files in row major format. However, each has its own ASCII
“header” file that contains georeferencing information. This dialog allows you
to create an ENVI or ARC header file from an existing RiverTools RTI file.
You can export any RiverTools grid (*.rtg).

• File → Export Vector → Channels — This new dialog allows you to export
the spatial coordinates and attributes of channel links or Horton-Strahler
streams stored in RTV files to other vector formats such as ESRI Shapefiles
and multi-column text files. Exporting files as ESRI Shapefiles or as an ASCII
table makes it easy to then import the data into another GIS or spreadsheet
program. You can choose any subset of 19 measured channel attributes for
inclusion in the output file. Listed attributes are defined in Appendix B,
“RiverTools Glossary” of the User’s Guide.
New File Import/Export Improvements What’s New in RiverTools 2.4
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• File → Export Vector → Boundaries — This new dialog allows you to
export the spatial coordinates and attributes of the boundaries of “shapes”
stored in a RiverTools Mask (RTM) file to an ESRI Shapefile. Exporting files
as ESRI Shapefiles makes it easy to then import the data into other GIS
software. The attributes area, diameter and shape factor are included in the
output file. Listed attributes are defined in Appendix B, “RiverTools Glossary”
of the User’s Guide.

Figure 1: File → Export Vector Dialog
What’s New in RiverTools 2.4 New File Import/Export Improvements



12 What’s New in RiverTools 2.4
Other File Menu Improvements

RiverTools 2.4 has added support for over 50 ellipsoid models of the Earth through
the File → Set Preferences – Planet Info category. Other File menu improvements
include a new Printing Options dialog, the ability to read text files within
RiverTools and the ability to control more aspects of the RiverTools session.

• File → Change Basin Prefix — This is a renamed and relocated version of the
former File → Edit Filename Info dialog, that allows you to select and work
with a previously extracted set of files for a particular basin in your DEM.

• File → Set Preferences - Planet Info category — This dialog lets you choose
from over 50 different ellipsoid models of the Earth, so that all length, slope
and area calculations are based on the currently selected ellipsoid. This is in
sharp contrast to most GIS programs that treat all pixels as if they have the
same geometry in these calculations. (In other programs, DEMs need to be
reprojected into an equal-area projection which leads to distortion and reduced
accuracy for measured quantities.)

The selected ellipsoid is used throughout RiverTools to calculate lengths,
slopes and areas for DEMs with geographic (latitude /longitude) coordinates or
fixed-angle pixel geometry. Prior to processing, you should choose the
ellipsoid that matches the source information for the DEMs you are using. For
USGS DEMs, it is usually the GRS 80 ellipsoid (North American Datum
1983) or Clarke 1866 (North American Datum 1927).

• File → View Text File — This new dialog provides a convenient way to view
any text file, including RTI files and log files, from within RiverTools.

• File → Printing Options — This new dialog allows printing at full resolution
and is streamlined for user efficiency. The information in this dialog is used by
RiverTools to set the size, position, orientation, and resolution of an image that
is to be printed to the printer via File → Print or to a PostScript file via File →
Print to File. The current aspect ratio (ratio of width to height) of the image in
the display window is preserved, but the width on the page can be set to any
value less than the paper width. You can also adjust the margins.

By default, raster images are printed at the highest resolution supported by
your printer. You can reduce the resolution below this value by entering a
reduction factor larger than the one shown. The width required to print a DEM-
based image at full resolution is shown. Vector-based images such as line
drawings and contour plots are unaffected by the reduction factor.
New File Import/Export Improvements What’s New in RiverTools 2.4
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Sometimes printers add a small amount to the margins which you may need to
subtract. You can confirm that margins are set correctly by printing to a
PostScript file via File → Print To File, and viewing it.

The “Print via screen capture” option provides a method for printing insets
such as scale bars and color bars that have been “burned into” a raster image.

• File → Set Preferences - General category — The values in this dialog
control various aspects of the current RiverTools session. All values less than
or equal to the NODATA threshold are treated as NODATA until the value is
changed. It is often necessary to set this value to 0.0 when working with DEMs
that border the sea.

Many processing routines process large data sets in pieces that are less than the
Max RAM block size. The default is fairly low and can be raised to a value
around half of available RAM.
What’s New in RiverTools 2.4 New File Import/Export Improvements



14 What’s New in RiverTools 2.4
Floating dialogs are dialogs that cannot fall “beneath” the main log window. In
this mode, an entire RiverTools session can be minimized into a single icon if
your platform supports this behavior.

Figure 2: Planet Info Preferences in File → Set Preferences
New File Import/Export Improvements What’s New in RiverTools 2.4
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New Display Menu Dialogs

New Display menu functions include the ability to import and display vector graphic
files and the ability to display a function as a plot once it has been saved as a text file.

• Display → Density Plot —This dialog has been improved so that you can now
choose from a droplist of stretches including histogram equalization, linear,
power laws, logarithmic, and “cycle plotting colors.”

• Display → Vector Graphic → ESRI Shapefile —This dialog allows you to
import an ESRI Shapefile, plot the entities, and display a table of associated
attributes. You can include vector data from Shapefiles in a multi-layer plot in
the standard way using Display → Multi-Layer Plot. Point, PolyLine, and
Polygon vector layers are all supported. This dialog can be used to re-import
and display RiverTools vector data after it has been exported to a Shapefile via
the File → Export Vector dialog.

• Display → Vector Graphic → DLG-SDTS — This dialog allows you to
import and plot a USGS Digital Line Graph (DLG) in SDTS format
(Topological Vector Profile). The USGS currently distributes its high-
resolution 1:24K DLGs for free in this newly mandated format on the Internet.
The older DLG-Optional format is not yet supported. You can include vector
data from DLGs in a multi-layer plot in the standard way using Display →
Multi-layer Plot.

• Display → Function — This dialog allows you to plot a function saved as one
or more columns of numbers in a text file. There are several places in
RiverTools where you can save a function or a profile in this format. You may
also wish to create your own functions with IDL.

Entries in a row can be separated by white space, commas, semi-colons, or
colons. Null lines and any lines that do not contain enough columns are
skipped. If the data is preceded by several lines of header information, you can
use the View File button to view the text file and count the number of header
lines. You must then enter this number in the text box that is labeled “Lines to
skip”.
What’s New in RiverTools 2.4 New Display Menu Dialogs
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Figure 3: Display → Vector Graphic → ESRI Shapefile Dialog
New Display Menu Dialogs What’s New in RiverTools 2.4
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New Prepare Menu Enhancements

Enhancements to the Prepare menu include the ability to compress and uncompress
files, an improved dialog for mosaicking RiverTools DEM grid files, the ability to
merge or concatenate a set of files and the ability to quickly create RTI files for
numerous USGS 1-Degree DEMs.

Merging RTV and RTM Files

This tool is for merging two or more files into a single file. Any set of RiverTools
mask (*.rtm) files that index the same DEM grid file can be merged. You can also
merge a set of RiverTools linkfiles (*_links.rtv) or a set of RiverTools streamfiles
(*_streams.rtv) that correspond to different basins in the same DEM. Each of these
basins will have its own basin prefix. It does not make sense to merge a linkfile and a
streamfile, or to merge two linkfiles or streamfiles that are associated with different
DEMs.

The new filename should have the same prefix and extension as the files that are
merged, such as “.rtm, “_links.rtv”, “_streams.rtv” or “.txt”. Otherwise, it may not be
recognized and will not appear in droplists of available files. For link and stream
files, it is helpful to use a new basin prefix.

You can also use this dialog to concatenate a set of text files. In this case, the order of
the files matters and will be the same as shown in the list.

The buttons on the right apply to the highlighted file in the list on the left. Use the
Add and Remove buttons to add or remove files from the list. Edit the filename filter
to restrict the set files in the Add dialog. When you have finished adding files to the
list, press the Start button to begin the merge operation.
What’s New in RiverTools 2.4 New Prepare Menu Enhancements



18 What’s New in RiverTools 2.4
Compressing and Uncompressing Files

The new Prepare → Gzip File and the Prepare → Ungzip File dialogs allow you to
compress or uncompress any file with the well-known GZIP algorithm. Filenames for
gzipped files should end in “.gz”. Compressed files take up less hard disk space and
take less time to transfer over a network. However, they must be uncompressed
before use.

Mosaicking RiverTools DEM Grid Files

The Prepare → Patch RTG DEMs tool is for “patching together” or mosaicking
RiverTools DEM grid files. The buttons on the right apply to the highlighted DEM
grid file in the list on the left. Use the Add and Remove buttons to add and remove
DEMs from the list. You can also preview a shaded relief image of the DEM (scaled
to fit the screen) with the Preview button, and view or edit an RTI info file for the
DEM by pressing the Edit Infofile button.

Figure 4: New Prepare → Merge Files Dialog
New Prepare Menu Enhancements What’s New in RiverTools 2.4
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When you have finished adding DEMs to the list, press the Start button. A preview
image showing how the DEMs fit together is displayed. Pixels with NODATA values
are shown in white. Regions for which no data is available are assigned the NODATA
value you have indicated in your Preferences.

Click and drag inside the preview window to select the region for which you want to
create a new DEM. Info about the selected region is printed in the output log. You can
select the entire window by clicking the right mouse button. This is the default
selection.

Press the Save New DEM button to create the new DEM, a “raw” DEM copy, and an
RTI info file.

The new “Options” menu at the top of the dialog lets you save a list of DEMs or to
use a saved list so you don't have to add them again. There is also a Change Backdrop
option that lets you choose between Density Plot or Shaded Relief backdrops.
Additionally, a new Label DEMs button on the patching preview window lets you
label each component DEM with its name.

Making RTI Files for USGS 1-Degree DEMs

RTI files are automatically created whenever you import a DEM with the File →
Import DEM dialog. However, USGS 1-Degree DEMs are sometimes distributed in
a nonstandard format where the lat/lon of the southeast corner is recorded in a 5-digit
filename prefix. The new Prepare → USGS 1-Deg. DEMs → Make RTI Files
dialog lets you make RTI files for a large number of USGS 1-Degree DEMs with this
naming convention. This dialog allows you to quickly create RTI files for a set of
USGS 1-Degree DEMs as long as the following two conditions are met:

• Converted to flat binary, row-major format.

• Given filenames with a 5-digit lat/lon prefix.

Some vendors re-distribute USGS 1-Degree DEMs in this format. Conversion to this
format can also be done as a batch process by using wildcards in the Prepare →
Convert Grid dialog.

Filenames must consist of a 5-digit lat/lon prefix. Bounding box info can then be
determined from the filenames. All other geocoding info for these DEMs can then be
determined automatically, even for DEMs in Alaska. Latitudes and longitudes in this
dialog refer to southeast corners.

RTI filenames will have the same prefixes and end in “.rti”. Once RTI files have been
created for a set of 1-Degree DEMs, they can easily be mosaicked with the Prepare
→ Patch RTG DEMs dialog described previously.
What’s New in RiverTools 2.4 New Prepare Menu Enhancements
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Enhanced Hydrologic Analysis Features

RiverTools 2.4 has a significantly expanded set of tools for hydrologic analysis that
provide the latest advancements and algorithms in the field. Examples include:

• Two new options for assigning flow directions through broad, flat valleys
through the Extract → Flow Grid (D8) function, based on the “imposed
gradient” method of Garbrecht and Martz (1997) and a new variant of that
method. See “New Extract > Flow Grid Features” on page 21 for more
information

• Support through the Extract → D-Infinity Grid routines for continuous flow
angles and multiple flow directions via the D-Infinity algorithms of Tarboton
(1997). See “New Extract > D-Infinity Grid Routines” on page 21 for details.

• The Extract → RT Treefile routine can now read a set of outlets from a text
file. See “Enhanced Extract > RT Treefile Routine” on page 22 for more
information.

• Several new D8-based Grid routines now feature the ability to compute
curvature of flow paths, flow distances, Horton-Strahler grids and watershed
subunits. See “New Extract > D8-based Grid Routines” on page 22 for more
information.

• The new Extract → D8-based Grid → Watershed Subunits dialog lets you
create a “watershed segmentation” grid and RTM file from a RiverTools
linkfile. See “New Extract > D8-based Grid Routines” on page 22 for details.

• Two new routines now feature the ability to derive a topographic index grid or
a product of two RiverTools grids. See “New Extract > Derived Grid
Routines” on page 23 for details.

• Additional peak, ridge, and grid threshold masking routines for creating
RiverTools mask files from grids. See “New Masking Routines” on page 24
for details.

• More options for area-altitude plots are detailed in the section, “Enhanced
Area-Altitude Function” on page 24.

• The Analyze → Subbasins → Shape Plots dialog has several new features.
This dialog lets you closely examine the shapes or “mask cells” in a
RiverTools mask file (RTM) one at a time. See “Enhanced Basin Shape
Analysis” on page 25 for more information.
Enhanced Hydrologic Analysis Features What’s New in RiverTools 2.4



What’s New in RiverTools 2.4 21
Note
Most functionality of the Extract → Data from RTV File, renamed from Export
Vector in RiverTools 2.0, has been superseded by the new File → Export Vector
dialog. See “New File > Export Features” on page 10 for more information.

New Extract > Flow Grid Features

The Extract → Flow Grid (D8) routine offers new options for assigning flow
directions within flats, including the Garbrecht and Martz (1997) “imposed
gradients” algorithm and a new variant. This routine performs two major tasks:

1. Creates a depressionless DEM from your original DEM. These files have the
file extensions “_DEM.rtg” and “_rawDEM.rtg”.

2. Creates a RiverTools D8 flow grid file using this new depressionless DEM.
This file will have the filename extension “_flow.rtg”.

There are now three different options for resolving flow direction in flats. “Iterative
linking” is the method used in version 2.0, but can produce parallel flow lines within
broad flat valleys. “Imposed gradients” is the method proposed by Garbrecht and
Martz (1997) which attempts to center flow within flat valleys and reduces parallel
flow. “Imposed gradients plus” is a new variant of the “imposed gradients” method
which further refines flow within flats to eliminate virtually all parallel flow. The
latter two methods are slower but yield better results when flats are an issue.

Note
Although these routines are very efficient they are computationally intensive and
may take several hours for very large DEMs. Your computer may be unresponsive
during this time.

New Extract > D-Infinity Grid Routines

The Extract → D-Infinity Grid → Continuous Flow Angles routine computes a
continuous flow angle grid and a slope grid using the D-infinity algorithm of
Tarboton (1997). This algorithm divides flow between one or two of a pixel's eight
neighbors, and is better-suited to modeling flow over divergent hillslopes than the D8
algorithm.

The D-infinity algorithm relies on a pre-existing D8 flow grid to assign a reasonable
flow angle in ambiguous situations. Flow angles are stored as floating point numbers
between 0 and 2 π, as measured counter-clockwise in radians from due east.
What’s New in RiverTools 2.4 Enhanced Hydrologic Analysis Features



22 What’s New in RiverTools 2.4
Computed values are saved in a binary file as double precision floating point
numbers (8 bytes per pixel).

The Extract → D-Infinity Grid → Upslope Areas routine computes a specific area
grid from a continuous flow angle grid, using the D-infinity algorithm of Tarboton
(1997). This algorithm divides contributing area between two neighbors, where one
is in a cardinal direction and the other is in a diagonal direction. This method is
better-suited to modeling flow over divergent hillslopes than the D8 algorithm.

A D-infinity flow angle grid stores flow angles as floating point numbers between 0
and 2 π, as measured counter-clockwise in radians from due east. Computed values
are saved in a binary file as double precision floating point numbers (8 bytes per
pixel).

Note
These routines are computationally intensive. It could take several hours to process
very large DEMs. Your computer may be unresponsive during this time.

Enhanced Extract > RT Treefile Routine

This routine creates a RiverTools treefile from a RiverTools flow grid. This dialog
can now read a set of basin outlets from a text file. The treefile is a vector-formatted
file with the extension: “_tree.rtv” while the flow grid is a raster-formatted file with
the extension: “_flow.rtg”. You can create a treefile by either:

1. Using a single outlet pixel that you selected and saved via the Extract →
Basin Outlet dialog.

2. Using all pixels that have a flow code of zero as basin outlets, which includes
the four edges of the DEM and the nodata pixels in the DEM.

3. Using a set of pixels whose coordinates are listed as two columns in a text file.
This option is new. A treefile can store data for many disjoint subbasins.

New Extract > D8-based Grid Routines

The Extract → D8-based Grid → Downstream Curvatures computes local
curvature along flow paths for every pixel in a DEM grid, using a RiverTools flow
grid and a slope grid. Local curvature is defined as the difference in slope between a
pixel and the adjacent pixel in the direction of flow, divided by the distance between
the pixel centers. This definition makes the curvature positive where a channel profile
is concave up and negative otherwise.
Enhanced Hydrologic Analysis Features What’s New in RiverTools 2.4
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Local slope is the slope defined by a pixel and the adjacent pixel in the direction of
flow, as “rise over run.” Curvatures have units of (1/km) and are saved in a binary
grid file as 4-byte floats.

The Extract → D8-based Grid → Flow Distance routine computes the flow
distance to the set of pixels in a RiverTools mask (RTM) file, for every pixel in a
DEM. It uses a RiverTools D8 flow grid and accounts for the latitude-dependence of
pixel dimensions in fixed-angle DEMs using the ellipsoid model specified in the
preferences.

RTM files can be created via dialogs in the Extract → Mask menu. If no RTM file is
specified, then the distance is computed to either the edge of the DEM or to the first
nodata pixel encountered. Computed flow distances are saved in a binary file as 4-
byte floating point numbers.

Note
This routine is efficient but computationally intensive and may take several hours
for very large DEMs. Your computer may be unresponsive during this time.

The new routine, Extract → D8-based Grid → Horton-Strahler Order, creates a
Horton-Strahler stream order grid from a RiverTools D8 flow grid. Values are saved
in a binary grid file as 1-byte integers.

Extract → D8-based Grid → Watershed Subunits routine uses a RiverTools “link
file” to create a RiverTools grid file mask for the “watershed subunits” that contribute
flow to the sides of interior links and the upstream ends of exterior links in a river
network. Together, these subregions form a hydrologic partition of a given drainage
basin.

RiverTools mask (RTM) files can be viewed with the Display → Masked Region
routine. RiverTools grid (RTG) files can be viewed with the Display → Density Plot
routine.

New Extract > Derived Grid Routines

The new Extract → Derived Grid → Topographic Index routine computes a
topographic index or “wetness index” for every pixel in a raster DEM, using
previously computed area and slope grid files. Topographic index is defined as:
TI = Ln [Area / Slope]. Computed values are saved in a binary file as 4-byte floating
point numbers. Zero-slope and edge pixels are mapped to (min(TI) - 0.1).

The Extract → Derived Grid → Product of 2 Grids routine computes the product
of any two RiverTools grid files that have the same dimensions as the currently
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selected DEM. Computed values are saved in a binary file with the same data type as
the grid with the highest precision.

Example application: In the idealized case of unit excess rainrate, the product of a
slope grid and an area grid is proportional to the flow power per unit width
perpendicular to the direction of flow.

The Extract → Derived Grid → Difference of 2 Grids routine computes the
difference of any two RiverTools grid files that have the same dimensions as the
currently selected DEM. Computed values are saved in a binary file with the same
data type as the grid with the highest precision.

The Extract → Derived Grid → Restricted to Mask routine creates a RiverTools
Grid (RTG) file from an existing RTG and RTM file. Pixels in the original RTG file
that are included in the RTM file are set to a nodata value in the new RTG file. One
use of this is to create a shaded relief image that is restricted to a particular basin.

New Masking Routines

The Extract → Mask → Peak Mask (1 pixel) routine creates a RiverTools mask file
for the pixels in a DEM known as “peaks.” Peaks are defined here as single pixels
that have a higher elevation than any of their eight neighbor pixels. Note that multi-
pixel peaks are excluded.

The Extract → Mask → Ridge Mask routine creates a RiverTools mask file for the
“ridge” pixels in a DEM. Ridges are defined in a simple manner here as pixels that
are higher in elevation than six or more of their eight neighbor pixels.

Extract → Mask → Grid Threshold Mask routine creates a RiverTools mask file
for the pixels in a binary RiverTools grid that lie in a user-specified range.

Extract → Mask → Connected-to-Seed Mask routine creates a RiverTools mask
file for the pixels in a binary RiverTools grid that lie in a user-specified range and
have a contiguous path of connectivity to the specified seed pixel. One use of this
dialog is to create an RTM file for one or more lakes.

Note
RiverTools mask files can be viewed with the Display → Masked Region routine.

Enhanced Area-Altitude Function

The Analyze → Entire Grid → Area-Altitude Function dialog now allows you to
create hypsometric curves in either the classic “percentage hypsometric curve” style
or in the style of a cumulative distribution function (CDF). The Analyze →
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Subbasins → Area-Altitude Function dialog allows you to create area-altitude plots
for individual basins or other “shapes” stored in a RiverTools Mask (RTM) file.

Enhanced Basin Shape Analysis

The Analyze → Subbasins → Shape Plots dialog has several new features. This
dialog lets you closely examine the shapes or “mask cells” in a RiverTools mask file
(RTM) one at a time. The button labeled Plot All Cells with Labels can be used to
display an image of all shapes in the RTM file, along with numeric labels that
indicate their relative position within the RTM file.

You can then enter the number of the shape you want to examine and press Start.
Click on the >> or << button to view the next or previous shape in the file. The
Current Avg button gives the ensemble average for all shapes up to the current
shape.

A selected shape is displayed along with its convex hull and the longest chord
contained within the shape. The area, diameter, and shape factor are reported in the

Figure 5: Percentage Hypsometric Curve Plot
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main log window for both the shape itself and the convex hull polygon. This
information can be used to quantify trends in basin shape.

Figure 6: Basin Shape Plot from Analyze → Subbasins → Shape Plots
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While the default option is to view shapes one by one, you can also display all of the
shapes as an animation sequence by choosing that display option. Since this could
take a while, you can stop the animation by pressing any key.

Figure 7: Order 3 subbasins from RTM file with labels
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Enhanced Interactive Window Tools

Each of the interactive window tools that appear in the Tools menu of a Display
window have been streamlined and enhanced with new functionality. Examples
include:

• An Options menu has been added to every window tool, which provides new
functionality and user control in a streamlined way.

• “Master windows” created via dialogs in the Display menu now “remember”
their data set information, so tools continue to work even after you change to
another data set. This can be very useful for comparing two data sets.

• UTM – Geographic – DMS coordinate conversion and display added to the
Value Zoom tool.

• Ability to edit any RiverTools grid with the Value Zoom dialog.

• Greatly improved Surface Zoom dialog, shown in the following figure, offers
style options of Mesh, Lego, and Shaded, more control over appearance, and
the ability to enter a factor that controls your apparent distance from the
surface. This feature allows you to create more compelling surface images.
Another new feature lets you select and use any RiverTools grid for coloring or
shading the surface.

• A more flexible Density Zoom dialog that lets you zoom in on a particular
location and to select and display any RiverTools grid.

• A new option for Channel Profiles lets you select and create a profile for any
RiverTools grid, rather than just the DEM. This option is useful for examining
how a gridded attribute like area or slope varies along a streamline.

• A new preference that lets you choose between a simple locator box or
crosshairs for showing the zoom location in the master window. Some of the
tools also let you change the color of the box and crosshairs.

• A new Xobjview tool that calls an IDL user routine by the same name. This
tool is similar to the Surface Zoom tool, but has a different interface.

• Improvements to the Reach Info and Flood Image tools

• You can now include scale bars and color bars in printouts by choosing the
new “Print via screen capture” option in File → Printing Options.
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Figure 8: The new Surface Zoom window tool
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Ease-of-Use Improvements

Streamlined Graphical User Interface

• Options menus in many dialogs and interactive window tools provide new
functionality in a streamlined way.

• New thermometer-style “Progress Dialog” shows progress for time-intensive
calculations, such as those in the Extract menu.

• Bitmap button toolbar provides fast access to commonly used dialogs.

Expanded Help Features

• RiverTools Help is now hyperlinked and is available from the Help menu.

• New hyperlinked tutorials in the Help → Tutorials menu. These are
automatically launched the first time you start RiverTools.

• New RiverTools command reference under Help → Contents.

• New context-sensitive Help buttons on all dialogs provide quick access to
specific help topics.

New Windows Menu

Several tools for managing windows have been moved from the File menu to a new
Windows menu. These include:

• Window → Find Window — Lists the title of each RiverTools window and
allows a selected window to be “brought to the front”.

• Window → Save Window As — Allows you to save the image in any window
to any of several supported image formats.

• Window → Close All Windows — Closes all RiverTools display windows.

• Window → Close All Dialogs — Closes all RiverTools dialogs.

• Window → Clear Log Window — Clears the text in the main RiverTools log
window.

• Window → Save Log Window — Allows you to save the text in the main
RiverTools log window to a text file.
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New Customization Features

New Naming Conventions

All of the low-level RiverTools routines have been renamed so as to have a “name
space” that does not conflict with the names of IDL or ENVI procedures and
functions. Each RiverTools command now begins with “RT_”. Commands that
launch a dialog or graphical user interface (GUI) now begin with “RT_GUI”. As
before, the remaining portion of a command name follows an easy-to-remember
“verb-adjective-noun” style, with separate words separated by underscores. These
low-level routines can be accessed by users who purchase RiverTools+IDL. For more
information, see the RiverTools Reference Guide.

Expanded Ability to Customize RiverTools

At startup, RiverTools will now restore any IDL “.sav” files that are found in the
RiverTools Menu folder. In addition to restoring IDL “.sav” files, RiverTools+IDL
will automatically compile any “.pro” files found in the RiverTools Menu folder at
startup. This makes it easier for users to extend RiverTools with routines they have
written or obtained from others. Using the file “user.pro” that is distributed with
RiverTools, this also makes it possible to permanently alter the User menu.
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New Data CD-ROM

RiverTools also comes with a CD-ROM full of interesting digital terrain data in many
different formats. This data is ideal for teaching a course with RiverTools and for
demonstrating the raster and vector import capabilities.

The CD-ROM includes high-resolution USGS DEMs for the dendritic river networks
of Kentucky, portions of the Grand Canyon near Powell Plateau, Arches National
Park (Utah), Canyonlands National Park (Utah), the Great Sand Dunes National
Monument (Colorado) and many other areas. Also included is a new Arctic
Bathymetry DEM from NGDC, GTOPO30 DEM subsets for Antarctica, Europe and
the USA, the MOLA DEM for the planet Mars, a NED sample for the Mount Saint
Helens region and a collection of “test surface” DEMs that are useful for testing and
model development. These surfaces include a cone, plane, V-shaped valley, pyramid,
saddle, monkey saddle and others.

In addition to raster data, the new CD-ROM also contains vector data, include a
collection of ESRI Shapefiles for the USA and USGS Digital Line Graphs for Beaver
Creek in Kentucky.
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Supported Platforms

The following platforms are supported in this release of RiverTools 2.4:

† For UNIX, the supported versions indicate that RSI software was either built on
(the lowest version listed) or tested on that version. It may be possible to install and
run RSI software on versions other than those listed if your version is binary
compatible.

†† Includes G3, G4 and iMac.

Platform Vendor Hardware
Operating

System
Supported
Versions

UNIX† SUN SPARC Solaris 8

Windows Microsoft Intel x86 Windows NT 4.0, 2000

Macintosh Apple PowerMAC†† MacOS 8.5, 8.6, 9.x

Table 1: Platforms Supported in RiverTools 2.4.
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